dcsimg
Login | Register   
LinkedIn
Google+
Twitter
RSS Feed
Download our iPhone app
TODAY'S HEADLINES  |   ARTICLE ARCHIVE  |   FORUMS  |   TIP BANK
Browse DevX
Sign up for e-mail newsletters from DevX

By submitting your information, you agree that devx.com may send you DevX offers via email, phone and text message, as well as email offers about other products and services that DevX believes may be of interest to you. DevX will process your information in accordance with the Quinstreet Privacy Policy.


Tip of the Day
Language:
Expertise: Beginner
Oct 16, 2000

WEBINAR:

On-Demand

Building the Right Environment to Support AI, Machine Learning and Deep Learning


Memory Initialization Problems

Question:
I cannot initialize the program after I have installed it. When I run "oninit", it seems to work, but then when I run "onstat" it tells me that the server is no longer running. When I type "onmode -k", I get a message saying it cannot use allocated memory. Sometimes when I run "oninit" I get a message saying "fatal error in shared memory creation."

The info is in my /etc/services file and I have modified the sqlhosts and onconfig file.

I have tried everything I know but cannot fix the problem. I am on Red Hat Linux 6.2 with 32MB RAM

Are able to tell me exactly how to create the shared memory?

Answer:
Check your Informix log file. It should be one of the last-modified files in your $INFORMIXDIR.

I'd be suspicious of the manual changes you've made. Make sure that the memory size is the smallest you can get away with. With only 32MB RAM, things may be getting a little tight.

DevX Pro
 
Comment and Contribute

 

 

 

 

 


(Maximum characters: 1200). You have 1200 characters left.

 

 

Sitemap
Thanks for your registration, follow us on our social networks to keep up-to-date