MTS 2 import package error

Question:
I attempted to import a package (*.PAK) file from another MTS server, and I got an error message. Both MTS servers are running the same version ofNT and MTS.

From the Packages Installed folder, I right clicked and selected New and then Package. Then I selected Install Pre-Built Packages. I then clicked on the Add… button, found the other server in Network Neighborhood, and located the PAK file. After I highlighted the PAK file and clicked Open, it was displayed in my list of selected package files as though it were properlyrecognized. I clicked Next and specified the MTS user and the appropriate password. Then I specified the directory where the component files were to be installed and clicked on Finish. Then an Errors Occurred window appeared, stating that “The component information is out of date.” This error is encountered even after I recreate the export package. I clicked on the Details… button, and the explanation was, “The component information in the package file is out of date. A component CLSID or IID has been regenerated since the package was exported. You must re-export thepackage.”

I have double-checked all CLSIDs and IIDs in the PAK file, and they are all correct. Is there a service pack to resolve this issue, or am I missing something?

Answer:
The only thing I could come up with is the following: The DLL containing the components for the specified package must be located in the same folder as the package file, otherwise an import error will occur.

Share the Post:
Share on facebook
Share on twitter
Share on linkedin

Overview

Recent Articles: