devxlogo

Debugger breakpoint mismatch

Debugger breakpoint mismatch

Question:
We have installed Powerbuilder 6.0.0. and have migrated applications. The application is working OK, but I am having a problem with the debugger. When I put a “break point” on an instruction on a script associated with a data window, the debugger seems to ignore it. If I put a bread point on a script on the window it picks that up. I can stop on the window break point and then single step and get eventually down to the data window script that was triggered by an event on the window, but this is a royal pain. I know the script in the data window is being executed, because I can see the results of the script. This application is not using any of the class libraries, since it was developed originally under release 4 before the class libraries came out. The break point on the data window is listed on the display, it just seems to skip right over it when running the debugger. Any ideas?

Answer:
This is caused by a bug in the PB 6.0.0 release. You will find that removing the comments from the script will clear up the problem. It is supposed to be fixed in PB6.0.1. You can also get a patch for the problem by calling Powersoft (1-800-8-SYBASE or +1 510-922-3555).

See also  Using Consumer Trust to Help Build Brands On Major Social Platforms
devxblackblue

About Our Editorial Process

At DevX, we’re dedicated to tech entrepreneurship. Our team closely follows industry shifts, new products, AI breakthroughs, technology trends, and funding announcements. Articles undergo thorough editing to ensure accuracy and clarity, reflecting DevX’s style and supporting entrepreneurs in the tech sphere.

See our full editorial policy.

About Our Journalist